Back to overview
Downtime
UK4 Outage
Mar 24 at 07:21pm GMT
Affected services
UK4
Resolved
Mar 24 at 09:06pm GMT
Service has been restored.
Affected services
UK4
Created
Mar 24 at 07:21pm GMT
We are currently aware of an outage affecting clients on our UK4 node. Our engineers are currently investigating this issue.
Affected services
UK4