Back to overview
Downtime

Obseq Website Outage

Sep 30, 2024 at 10:07am UTC
Affected services
Obseq Website

Resolved
Sep 30, 2024 at 10:35am UTC

This has now been resolved.

Created
Sep 30, 2024 at 10:07am UTC

Our website is currently experiencing difficulties due to a server outage. We apologise for any inconvenience caused.